Please Make Sure Agents Confirm the Donation Amount

Incident Report for Comic Relief

Resolved

This incident has been resolved.
Posted Mar 15, 2019 - 22:59 UTC

Monitoring

Hello, please make sure agents are confirming the donation amount after it has been entered into the entry box!
Posted Mar 15, 2019 - 20:21 UTC
This incident affected: Call Centres.