Welcome to Red Nose Day 2019!

Incident Report for Comic Relief

Resolved

This incident has been resolved.
Posted Mar 15, 2019 - 19:05 UTC

Investigating

Hello! Hopefully you are all logged in now and ready for a big night!
Just to let you know we are expecting the first to spikes in calls to be after an appeal film at 7:35 and a big moment at 7:55.
Good luck guys and thanks again for being apart of Red Nose Day 2019!
Posted Mar 15, 2019 - 19:04 UTC
This incident affected: Call Centres.