Appeal Film

Incident Report for Comic Relief

Resolved

This incident has been resolved.
Posted Mar 11, 2019 - 15:40 UTC

Investigating

Appeal film scheduled for 19:30 - man the phones!
Posted Mar 11, 2019 - 15:40 UTC
This incident affected: Call Centres.