Helpdesk Update - stay on line to explain issue before putting people

Incident Report for Comic Relief

Resolved

This incident has been resolved.
Posted Mar 15, 2019 - 23:01 UTC

Monitoring

Hi guys, please make sure agents who have callers who need to go to the helpdesk stay on the line to explain to our helpdesk what the problem is before putting callers though.
Posted Mar 15, 2019 - 19:31 UTC
This incident affected: Call Centres.